Elevator Out Of Service

Incident Report for GCPH Status

Resolved

The elevator is back in service.
Posted Jun 17, 2024 - 13:48 EDT

Investigating

The elevators are out of service. We will send out updates as we get them.
Posted Jun 17, 2024 - 09:19 EDT
This incident affected: Facilities.