Phones

Incident Report for GCPH Status

Resolved

This issue has been resolved. Please let us know if you are still experiencing phone issues.
Posted Oct 11, 2023 - 14:25 EDT

Identified

We are aware that there is an issue with the phones. Jacob and I are working on it and may need to initiate a reboot of some or all the phones. We will update and let you know when we have worked out the issue.
Posted Oct 11, 2023 - 12:50 EDT
This incident affected: Phones.