Phone System Unable to dial out or receive outside calls

Incident Report for GCPH Status

Resolved

Phones should now be able to make and receive calls outside.
Posted Jun 07, 2024 - 13:35 EDT

Investigating

We are working with Spectrum to resolve this issue. We will update as we find out more.
Posted Jun 07, 2024 - 11:58 EDT
This incident affected: Phones.