BambooHR Down

Incident Report for GCPH Status

Resolved

BambooHR is now up.
Posted Jul 15, 2025 - 09:07 EDT

Investigating

We are awaiting updates from BambooHR for this issue.
Posted Jul 15, 2025 - 07:57 EDT
This incident affected: BambooHR.