HDIS is down

Incident Report for GCPH Status

Resolved

We have restored HDIS. Let us know if you have any issues.
Posted Mar 11, 2024 - 09:08 EDT

Identified

We are working on bringing HDIS back online. We will provide updates when progress is made.
Posted Mar 11, 2024 - 08:34 EDT
This incident affected: HDIS.