The elevator has been repaired and is back in operation.
Posted Mar 12, 2024 - 14:29 EDT
Update
As a follow up on the elevator motor. I spoke with Chris, our elevator technician, the part was ordered on Thursday, Feb 29, and is currently in transit from overseas. This longer lead time is due to the international nature of the shipment.
Chris and his team are scheduled to install the part as soon as it arrives at their location. They typically receive deliveries in the morning, so the installation should occur on the same day.
We will keep you updated on any further developments and am available to answer any questions you may have in the meantime. Please do not hesitate to reach out if you have any questions.
Posted Mar 07, 2024 - 10:23 EST
Identified
Everyone,
Issue Description: The hydraulic pump motor responsible for the elevator's operation is currently non-operational, rendering the elevator out of service.
Resolution Plan: Our contracted support provider, Otis, has initiated the procurement process for a replacement pump motor. Upon receipt of the motor, Otis will promptly dispatch our designated technician to facilitate the repair.
Estimated Timeline: As of now, we anticipate the delivery and installation of the new motor to occur during the early part of next week, specifically Monday or Tuesday. Efforts are being made to expedite this process to minimize service disruption.
Communication Strategy: Regular updates will be provided as new information becomes available, ensuring all employees are kept informed of the progress and any adjustments to the timeline. Updates will be provided through this status page.
Please let me know if you have any questions or concerns.